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RMRTask: Quick start 
RMRTask 'Extended ToDo Manager’ allows you to record and monitor your various tasks (To-
Do's) in a structured way. It comprises 2 screens: 

1. The main Task Group screen for entry, viewing and scheduling of active tasks, 

2. An Archive screen to view the completed task history. 

Task Group files can be created to represent separate work, home, hobby or personal areas. 
Define Project and Type categories to allow you to categorise various assignments and their 
actions. 

Tasks can be entered with a description, assigned to the categories, and be set with a due date, 
priority, alarm, repeat, and extended description. Links can also be set up to other files. 

Several priority schemes, screen options and configurations can be set, and the tasks can be 
sorted in various hierarchies. 

To assist with scheduling and managing your time the date and priority of tasks can easily be 
changed. 

Completed tasks can then be struckout and either deleted or, more typically, archived to a 
separate file as a permanent record. 
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Registering the program 
If you wish to register your copy, which will then give you full access to the program and no nag 
screen, the cost is £10 or US$15 or €15. There are several ways to register: 

Credit Card: 

If you wish to register on-line using a credit card you have 2 options: 

PAYPAL: 

We support the PayPal system for transferring money, as that avoids the $5 handling charge 
put on by REGNET. Simply send the money to registrations@rmrsoft.com quoting the program 
name, RMRTask (Nokia), and we will send the registration code to you within a few hours. 

If you are not already signed up for PayPal it is very straightforward. Just go to 
http://www.paypal.com/ and follow the instructions. You even get a $5 bonus for signing up. 

REGNET: 

Alternatively, you can register on the WWW through RegNet, the Registration Network (note 
that paying by this method will involve an extra US$5 handling charge and if you live in the EU 
they will also charge VAT). RegNet can be reached by e-mail: orders@reg.net, or on the World 
Wide Web: http://www.reg.net/  or in the USA by calling 1-800-WWW2REG (1 800 999-2734) or 
the easiest way is by following the links from our Website at: 

http://www.rmrsoft.com/ 

RMRTask (Nokia) has been allocated the RegNet Number 11461 and this should be quoted. 
The notification tends to get to us within 12 hours and we reply within another 12 hrs. 

By Post: 

Payment can be made by post as: 

• UK cheque in GBP (NO cheques in foreign currencies or on non-UK banks) 
• International Bankers Draft in Sterling 
• Cash - 'real folding' money in any currency 
• US$ checks (send to the USA address) 

Please make any cheques (checks) payable to 'RMR Software'. Include a stamped, self-
addressed envelope or provide an e-mail address, and send the payment to either of these 
addresses: 

RMR Software 
c/o 46 Mortimer Road 
Kempston 
Bedford MK42 8RE 
ENGLAND 
 
RMR Software  
c/o 6000 Natick Court 
Burke, VA 22015 
USA 

We will then send you a unique code to enter with the Register menu option, which will allow 
you unrestricted use of the program. 

If you have any questions, we can be contacted at  support@rmrsoft.com 

mailto:registrations@rmrsoft.com
http://www.paypal.com/
mailto:orders@reg.net
http://www.reg.net/
http://www.rmrsoft.com/
mailto:support@rmrsoft.com
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Managing Task Groups 
Task Groups are the top level categorisation. They allow you to store lists of completely 
unrelated and independent tasks in separate files. Any number of Task Group files can be 
created and used how you wish. Typically you would have Groups for Work and Personal 
Todos, but set them up as you require. 

Use Create new task group from the File menu to start a new group file. 

• Enter a Name for the file. 
• Select the Folder and Disk where to store the file. 
• Use Link to Archive to specify which archive file is to be associated with this task group 

(only available after you have created archive files). 

Use Open task group to switch between task group files if you have more than one, or simply 
use the left / right arrow keys to cycle through them. 

Use the Password option to set password protection for individual Groups if required. 

Use File > More > Update group details if you need to change the on-screen title of the Task 
List, or change the linked archive file. 

Use More > Delete Group to completely remove a task group if you are completely finished 
with it. 

Use More > Move Group to move the group file to another folder on your communicator (do not 
try to do this with the file manager or the program will lose touch with its location!) 

The More menu also has a Rebuild files option. This does some cleaning up of all the data 
files. It compresses them, refreshes the Category titles, resets the internal pointers and rebuilds 
the indices. Use this option after you have Updated/Deleted a Category name, or whenever you 
think something is not quite right with the data files. 

The Printing options are also in the File menu. 

Use the Add to desk option to put a shortcut for your task group file on the desktop. 

In the Data menu there are Backup and Restore options to allow you to keep a copy of your 
data elsewhere on the system for security, and to restore it if necessary. 

Project and type categories 
Two separate categories - Projects and Types - are available for assigning tasks against. Use 
them as you wish but typically Projects would be for major sub-divisions or assignments, and 
Type for the activities and actions involved. 

Use the Categories menu option to Enter Project / Type categories. 

• Define the Type, whether it is a Project or Type category, 
• Give it a Title, 
• Define the Colour so they show up differently on the screen, 
• Add any free text description of the category (for reference only). 

The Categories menu also has options to: 

• Update categories to rename them, or change the colour or description, 
• View or change the Description 
• Delete them completely. 
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Define the 'Project' or 'Type' labels themselves (as seen on screen and in menus) using 
General Preferences > Terminology. These titles are Group specific. 

If you don't wish to use or display one or other or both of the categories, they can be individually 
disabled in View Preferences > Usage. 

Categories are 'global', so you only need to create them once and they will be available in all 
task groups. 

Task screen 
Each Task Group file can hold an unlimited number of entries. The top line shows a counter of 
the highlighted task and the total number of tasks in the Group. The name of the Group is 
shown at the bottom left and can be changed with Update group details. 

Use the Tools > View Preferences and General Preferences options to configure the program 
operation to your needs. Use the Categories menu functions to set up relevant Project and 
Type categories for assigning tasks against (see the separate Help items). 

Various hierarchical Sort methods can be chosen (see separate Help item), so that tasks will be 
dynamically ordered on screen as they are entered or updated. 

Undated or unprioritised tasks show with -- in the relevant fields, and will always be at the 
bottom of the sort order. 

The PARXL columns identify the attributes set for individual tasks: 

• Priority 
• Alarm 
• Repeat 
• eXtended description 
• Linked file 

The symbols used for these are configurable from View Preferences. 

If you have selected the option in View Preferences, once the task is within a week, the date 
will change to show the day name instead, and then 'Today' as the defined Due Date is 
reached. 

Overdue tasks are shown with their Due Dates in bold (optionally in italic or colour). 

When tasks have been entered you can view and manage them on screen in various ways: 

• Mark them as Tasks in-progress, Ctrl+I, in italic (optionally in bold or colour). 
• Use the single key modifiers to change the dates and/or priorities to reorder them. 
• Use Display as bar, Ctrl+B, to show a graphical progress time bar representing the 

'today' position relative to the entry and due dates. This can be scrolled down the task list 
on screen. 

• Strikeout tasks as you complete them, then delete or archive them as a permanent record. 

When completed tasks are struck out they get moved to the top of the screen. You may need to 
scroll up to view these. 

The View menu lets you view any linked Word and Sheet files that you have associated with a 
task. In the View menu there are also options for Switch title to remove the screen title, and 
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Full screen to remove the left and right information and button bars for more screen space. 
Four sizes of text are available with the Zoom options. 

Moving around 
There are various shortcut methods for moving around the screens: 

• Up/Down arrow keys select entries. 
• PgUp/PgDn to move a screenful at a time. 
• Home/End to go to the top or bottom entry in the file. 
• Ctrl+Q to switch view between the main and Archive screens. Esc also returns. 
• L/R arrow keys, or Ctrl+O to switch between task groups and archives (if you have 

more than one). 
• Ctrl+arrows act as PgUp/PgDn/Home/End. 
• the joystick also acts as a cursor. 

Task priorities 
Several schemes are available for defining the priority of ToDos. Set up your preferred system 
in General Preferences > Priority. Manual Priorities can be different for each Task Group, with 
the choice of: 

• Numeric '1-2-3...', up to 9 levels, 
• Alphabetic 'A-B-C...', up to 9 levels, 
• Simple 3 level 'Hi-Med-Lo'. 

1, A and Hi are the highest priorities. 

An Auto Priority system is also available where the program automatically increases the 
priority of tasks as the Due Date approaches and the task becomes more urgent. In the 
General Preferences define the number of days previous to the Due Date when: 

• Low priority tasks become medium, 
• Medium priority tasks become high. 

Use Tools > Setup Defaults > Priority to define your normal priority level to preset in the Enter 
new task dialog. 

Then when using Enter new task select the required priority in the dialog, from: 

• The alpha/numeric priority from the scheme set up for the Group (initially set to the default 
priority), 

• Auto to enable the automatic changing of task priorities, 
• None to make the task unprioritised if you want it in the list just as a reminder. 

Task priority can later be changed through the Update task dialog, or more simply on screen 
using just the appropriate numeric or alphabetic keys (e.g. use 2, B or M as appropriate to the 
priority system to set the second highest priority). 0 (zero) will make the task unprioritised. 

Entering tasks 
Add tasks to a task list using Enter new task from the Edit menu, or the Add button, or Ctrl+A, 
or simply the Enter key, and complete the following details: 

• add a Description 



 RMRTask (for Nokia Communicator) Extended ToDo Manager 

www.rmrsoft.com page 7 

• set if it should be Dated or not, or 
• set a Due date, 
• set a Priority value, or None for an unprioritised task, or  Auto to use the auto-priority 

system, 
• assign Project and Type categories, or use New to create a new category. 
• set the Entry date if different to the current date (i.e. you forgot to create it previously!) 
• define the Colour for the task description text. 

Then as necessary: 

• Use the Text button to write an extended description of the task. 
• Use the Advanced button to turn on a Repeat and set a Period and Interval. 
• Use the Advanced > Alarm button to turn on an Alarm and set a Time, Days previous, 

and Sound.  (This is temporarily disabled on the 9300/9500 as the Alarm code provided 
by Symbian causes the phone to ‘lockout’) 

• Use the Advanced > Links button to define a link to an existing Word or Sheet file. 

In addition the Edit > Advanced menu has various other options for entering tasks. These allow 
you to: 

• Enter default task to add a task from your pre-defined entry list (see separate Help 
entry). 

• Enter last task again. 
• Copy/Move task to use an existing task in the list again, or in another Group. 

The date and time of the task is automatically recorded on entry unless you have selected Task 
duration for the Time field in the preferences menus. 

Updating tasks 
To update any task attributes first highlight it in the list and then use Edit > Update task, 
Ctrl+U, the Tab key, or tap on the Update button on the CBA. The dialog is similar to that when 
adding a task. Make any necessary changes. 

Note that the original Entry date (and time/duration, if set to be displayed) of the task is also 
shown in the Update dialog. 

The Edit > Advanced > Reset to today function allows you to quickly change the dates of 
single, tagged, overdue, or all tasks. Or simply use the T key. 

Remove tasks if entered in error or not required with Delete task, Ctrl+D or Delete key. 

Note: Deleted tasks are lost forever and not archived. 

Entering default tasks 
If you find you are often entering similar tasks with the same information except for the date or 
priority, then set them up as Default entries. 

Simply use the Tools > Setup defaults options Shift+Ctrl+S. Select Add entry, give it a unique 
recognizable Name and enter all the normal details that will never change, and save it. 

When you want to use a Default task in a Task Group, use Add default task from the Edit > 
Advanced menu, or Ctrl+C, or simply the Shift+Enter keys instead of the normal Enter. Select 
the required name and all the information is automatically filled in. 
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Use the Setup defaults > Update entry option to amend the details, or Delete entry to remove 
any default tasks you no longer need. 

Default tasks are Group specific. 

Task scheduling functions 

Single key task scheduling 
Use 'single key switching' to modify tasks on screen. Various modifier keys can be used: 

W - increases Due Date by a day 
Q - increases Due Date by a week 
O - decreases Due Date by a day 
P - decreases Due Date by a week 
T - changes Due Date to 'today' 
N - sets the task to undated 
1-9, A-I, HML - changes the Priority 
0 – (zero) makes a task unprioritised 
R - toggles the Repeat on/off 
A,M - toggles the Alarm on/off (if keys are not otherwise used for priorities) 
S - flags a task as 'in progress' 
X - resets the start time (if used) 
V - resets the end time (if used) 
Spacebar - to add / view an Extended Description. 

You can enable / disable many of these single keys in General Preferences > Single keys. 

Repeating tasks 
Repeats can optionally be set on tasks using the Advanced buttons in the New Task or 
Update Task dialogs. Set the Repeat with: 

• Period as Daily, Weekly, Monthly, Annually or Last day in month. 
• Interval for the frequency. 

Setting Weekly and 2 would offer to re-enter the task for 2 weeks after the original Due Date 
when it is completed. 

Repeated tasks are identified in the task list with a symbol in the R column. The symbol itself is 
configurable from View Preferences > Symbols. 

In addition the single attribute key R works to set a Repeat on an existing task, or to turn off an 
already set repeat. 

When a task marked as a repeat is completed and struckout, you will be given the option to re-
enable it with a new Due date. 

Task alarms 
(Note: This option is temporarily disabled on the 9300/9500 as the Alarm code provided by 
Symbian causes the phone to ‘lockout’) 
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Reminder Alarms can optionally be set on tasks using the Advanced > Alarm buttons in the 
New Task or Update Task dialogs. Set the Alarm with: 

• Alarm time. 
• Days previous to the Due Date. 
• Sound required. 

Alarms are passed to and handled by the built-in Clock application. Up to 8 alarms can be set 
from RMRTask depending on how many other existing alarms are in Clock. 

Alarms set from RMRTask are identified in the Clock application with a text prefix which is 
configurable from General Preferences > Terminology. 

Alarmed tasks are identified in the task list with a symbol in the A column. The symbol itself is 
configurable from View Preferences > Symbols. 

In addition the single attribute key A or M (depending on which is not being used by the priority 
system) works to set an alarm on an existing task, or to turn off an already set alarm. 

Sorting tasks 
Use Data > Sort tasks to set up to 2 heirarchical levels of sorting on the tasks in the group: 

• Fields 1 and 2 can be set to sort on Date, Priority, Project, Type, or Description. 
• Direction of sort can be either Ascending or Descending. 

Tasks will have primary sorting on the 1st field, then be sub-sorted by the 2nd field. The chosen 
sorting scheme is identified at the bottom right of the screen. Set Field 2 to None if you only 
want one level of sorting. 

The sorting method can be different for each Task Group. 

Timed tasks 
Turn on the Use time option in Tools > View preferences > Usage, to enable an extra time 
column on screen (you may also need to remove the button and information bars for extra 
space), together with extra Time entry fields. 

This allows the Task entry time to be recorded in the New task and Update task dialogs. If a 
task entry is highlighted, the time can be quickly set to the current time using Reset time in Edit 
> Advanced menu, or Ctrl+X, or just X. 

Alternatively, Tools > General preferences > Settings has a Time method setting allowing 
you to record Task duration instead of Entry time. 

When Task duration has been selected, the time can be reset to the current time using the 
Edit > Advanced menu option for Start task, Ctrl+X, or just X. When the task is finished, you 
can evaluate the time by using Finish task, Ctrl+V, or just V. 

Note: Task duration is only intended for use on short tasks, such as meetings, that last only a 
few hours. 
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Completing tasks 
As you actually complete your tasks, 'Strike' them out from the list with Tasks > Strikeout, 
Shift+Ctrl+X or the Strikeout command button. Later you can periodically archive the struckout 
tasks from the active ToDo list as a permanent record of your completed activities. 

You can 'Tag' multiple tasks for strikeout using the Shift+Up or Shift+Down arrow keys, when 
they are marked with a symbol next to the description. 

The following list describes the menu options and methods for removing tasks from a Task 
Group. These can be selected to work on All tasks, the Single highlighted task, the tasks 
marked as Strikeout, or the Tagged tasks: 

1. Delete tasks, Ctrl+D or Delete key. Tasks are completely removed from the Group with no 
record made. Any repeat is NOT enabled. 

2. Remove tasks, option in Archive/Remove tasks, Shift+Ctrl+G. Tasks are completely 
removed with no record, but any repeat set IS enabled. 

3. Strikeout tasks, Shift+Ctrl+X. Allows a Completion date to be set. Any repeat IS enabled. 
Tasks have their date and description text 'struck out' (displayed with a line through the text), 
and are moved to the top of the screen as a temporary record. You may need to scroll up to 
view these. 

A struckout task can be reinstated as a due task by using Shift+Ctrl+X on it again. 

4. Archive tasks, option in Archive/Remove tasks, Shift+Ctrl+G. Tasks are moved to a 
separate archive file for permanent record. The Due Date or Completion Date is kept, and 
any repeat IS enabled. 

Alternatively, in View preferences > Tasks you can set the Action completed tasks option 
to Archive instead of Strikeout. Under this condition the Archive Shift+Ctrl+G or Strikeout 
Shift+Ctrl+X functions will directly move tasks to the archive file when completed. 

Archive screen 
This history screen allows you to view completed tasks previously archived from the Task Group 
screen. Use Switch view, Ctrl+Q to view the archives. Depending on your General 
preferences > Archive setting this will either open the last used archive, the default named file, 
the archive file related to that Task Group as defined by the Link option in Group Details, or 
allow the file to be selected on entry. 

One or several archive files can be created as required. The File menu has options to Create 
new archive, Open archive file, Rename archive and Delete archive. From the Tools menu 
you can specify an alternative Folder and disk for storage of the archive files if required. 

A Sort option allows you to order the tasks the same way as in the main Group screen. 

From the Edit menu options allow tasks to be Unarchived, Ctrl+U (put back into a Task Group), 
or completely Deleted, Ctrl+D. Multiple entries can be actioned by first tagging them using 
Shift+Up or Shift+Down arrow keys. 

If the Archive file becomes too large you can Reset start date with Ctrl+R. 
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Exporting tasks 
Use the Export option in Task Groups and Archives to export the complete task details to a text 
file in ASCII (<TAB> delimited) or CSV (comma separated) format. 

These can then be copied from your communicator for use in other PC programs, or used within 
the built-in applications. 

Configuring RMRTask 
One of the strengths of RMRTask is its configurability. The Tools menu has many Preference 
options for configuring the display and operation of the program, although the defaults should 
be acceptable to start with for most people. Many of the preferences can be set differently for 
each Task Group. 

View preferences 
View preferences, Ctrl+K has many options for configuring the program display. The following 
can be set: 

Display page: 

• Font type allows Arial or Times Roman. 
• Date format gives a choice of various international date formats. 
• Show days of next week determines whether to show dates in the coming 7 days as day 

names. 
• Include today in ‘Overdue’ determines whether tasks for 'today' are shown as overdue. 

Tasks page: 

• Action completed tasks sets whether completed tasks are struckout or archived directly. 
• Show overdue tasks in bold, italic or normal text, or in a colour. 
• Show tasks in progress in italic, bold or normal text, or in a colour. 
• Show description in text view sets whether the main task description is shown as a title 

line when viewing the extended notes. 

Usage page (applies only to the current group): 

• Use time. Sets if task entry and/or duration times are to be recorded, and shown on 
screen as an extra column. 

• Use first category sets whether the Project category is to be used and displayed on 
screen. 

• Use second category sets whether the Type category is to be used and displayed on 
screen. 

• Hide future tasks sets whether tasks in the future should be hidden from screen view. 

Flags page: 

• Sets which of the on-screen task indicators you wish to display: A-Alarms, R-Repeats, X-
Extended description, L-Linked files. 

Symbols page: 

• Sets the character symbol you wish to use to identify Alarms, Repeats, Extended 
descriptions and Tagged tasks. 

• Use default symbols allows you to reset the characters if you mess up the settings. 
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Colour page: 

• Default colour specifies the normal colour for the task description. 
• Header window sets the colour for the column titles. 

General preferences 
General preferences, Shift+Ctrl+K has many options for configuring the operation of the 
program. The following can be set: 

Settings page: 

• Prompt for repeat sets whether you are prompted to re-enter repeated entries when 
completing tasks, or to enter them anyway. 

• Time method specifies if the time field (if used) shows the Entry Time or Task Duration. 
• Default to undated determines whether the enter task dialog pre-sets to undated or not. 
• Default alarm sound selects from those installed. 

Terminology page (applies only to the current group): 

• Category one title and Category two title allow you to name the two Category titles 
(default to Project and Type), 

• Prefix in Alarm specifies the identifying name applied to entries passed to the Alarm 
Clock application. 

Archive page: 

• Default archive sets which file is shown when viewing archive files, selected as Last 
used, a specified Default file, Select on entry or to the Linked archive for the task 
group. 

Single keys page: 

• Specifies whether various single keys can be used for changing task attributes for Date, 
Priority, Repeat, Alarm, In Progress and to Reset time. 

Keys page: 

• Sets whether the Enter or Tab keys perform the New task or Update task actions. 

Priority page (applies to the current group): 

• Type. Sets the manual priority scheme as A-B-C- or Hi-Med-Lo or 1-2-3-. 
• No of levels sets how many priority levels between 1 and 9 you want to use for the 1-2-3 

and A-B-C schemes, 
• Low to Middle defines the number of days prior to due when the Auto priority scheme 

progresses a task from low to medium priority. 
• Middle to High defines the number of days prior to due when the Auto priority scheme 

progresses a task from medium to high priority. 

Backup page  

• Auto. Sets the automatic backup option. 
• Start date is when you want the backup to be actioned for the first time. 
• Prompt sets whether you want to be prompted before each automatic backup. 
• Folder CBA Button defines where you want the Backup to be located. 
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